Pontiac G8 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi Gang,

I've recently purchased a 2009 G8 GT with about 26000 miles on it. After I got it home, the TPMS kept faulting out. Took back to dealer, they did the reset, problem persisted. Took it back, the replaced 3 sensors. Problem persisted. Took it back and the removed the rear tint and replaced the receiver. The problem still persists.

It seems that I drive it for about 20 miles then the fault appears. After the car is shut off for a while, the fault clears. I have put it in engineering mode and when the fault comes up even there the psi goes to --. it is currently at the dealer and they are waiting to hear from "tech support" to help identify the issue. I know some have had issues, but is there any clear answer to this.. Is this a persistent problem. Tires and wheels are stock.

Thanks in advance!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
You can go to your dealer and have your TPMS reset.
I've been back to the dealer a few times. Resetting does not do the trick. it's been back to the dealer a few times and 3 of the 4 wheel sensors have been replaced, and I believe that the unit has been replaced as well. Still...after 20-40 min, the tpms fault comes on. It is not always consistant though so I am not sure what the problem is. The last time I went to the dealer they said they could not reproduce the problem. Thinking of taking it to a buick dealer that used to sell pontiacs. Perhaps they know of the issue and can correct it.
 
1 - 4 of 4 Posts
Top