Pontiac G8 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Lately when I start my G8 on cold mornings it shutters and almost stalls. The colder the temp, the worse the shutter is but after about 10 to 20 seconds it goes back to a normal idle and runs fine. I had read it might be the IAT and MAF so I hooked my scanner up to it, the IAT stays at 32°F regardless of how long its been running. However another function on the scanner is power- up IAT, and that one will gradually go up as I drive and the engine heats up. I'm curious as to what the difference is between the IAT and power-up IAT, if my IAT is actually bad, and what would most likely be causing this issue. Also my fuel economy seems to be suffering.
 

·
Registered
Joined
·
2 Posts
Truly, this article is really one of the very best in the history of articles. I am a antique ’Article’ collector and I sometimes read some new articles if I find them interesting. And I found this one pretty fascinating and it should go into my collection. Very good work! 먹튀검증
 

·
Registered
Joined
·
1 Posts
Lately when I start my G8 on cold mornings it shutters and almost stalls. The colder the temp, the worse the shutter is but after about 10 to 20 seconds it goes back to a normal idle and runs fine.
I had read it might be the IAT and MAF so I hooked my scanner up to it, the IAT stays at 32°F regardless of how long its been running. However another function on the scanner is power- up IAT, and that one will gradually go up as I drive and the engine heats up.

I'm curious as to what the difference is between the IAT and power-up IAT, if my IAT is actually bad, and what would most likely be causing this issue.

Also my fuel economy seems to be suffering.

For more information about https://gmbbodyforum.com/japan-cars/infiniti please visit the website here cold air intake for eu cars.
How do you know if your air intake sensor is bad?
 

·
Registered
Joined
·
1 Posts
Lately when I start my G8 on cold mornings it shutters and almost stalls. The colder the temp, the worse the shutter is but after about 10 to 20 seconds it goes back to a normal idle and runs fine. I had read it might be the IAT and MAF so I hooked my scanner up to it, the IAT stays at 32°F regardless of how long its been running. However another function on the scanner is power- up IAT, and that one will gradually go up as I drive and the engine heats up. I'm curious as to what the difference is between the IAT and power-up IAT, if my IAT is actually bad, and what would most likely be causing this issue. Also my fuel economy seems to be suffering.
Lately when I start my G8 on cold mornings it shutters and almost stalls. The colder the temp, the worse the shutter is but after about 10 to 20 seconds it goes back to a normal idle and runs fine. I had read it might be the IAT and MAF so I hooked my scanner up to it, the IAT stays at 32°F regardless of how long its been running. However another function on the scanner is power- up IAT, and that one will gradually go up as I drive and the engine heats up. I'm curious as to what the difference is between the IAT and power-up IAT, if my IAT is actually bad, and what would most likely be causing this issue. Also my fuel economy seems to be suffering.
Seems like we are having the same issue, were you ever able to figure out the issue or find a fix?
 
1 - 5 of 5 Posts
Top