Pontiac G8 Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I own a 2009 G8 GT and often experience a lifter/valve ticking noise when cold starting the engine. I have brought the car into the dealership (3) times to clear this problem and they say, they do not hear the ticking noise when they start it.
On another G8 site, I have found other owners who complain of this problem, and have had the oil pump changed and relieved the problem.
My car is under warranty, and I am hoping someone out there has delt with this issue and can pass on any remedy as in published information or actual experience with their dealership, and what was found and repaired.
Thanks ........ Hoolie
 

·
Registered
Joined
·
1 Posts
The simple answer is: Take it in and have the dealer give you a loaner until they get it fixed. There are several reasons this can occur. Some of the reasons include bad fuel (which isn't really fixable until you get a good high grade fuel fill-up), valve issues (carbon build-up or just general valve lubrication issues), intake manifold issues (needs cleaning or other issues), possible water in the gas tank (Walmart sells stuff to remove it), or other possible issues. In general, if you do an oil change, fill the tank with premium, poor in 2 bottles of fuel injection cleaner and possibly water removal bottle (basicaly the same thing, but does have a few different ingrediants), and the problem still persisists after driving it for 20-50 miles on the freeway at 60-70 MPH (not puttering around town), then you need to have the dealer diagnose the problem and fix it.
 
1 - 2 of 2 Posts
Top